Bug #199

Reflects are not rendered correctly in opengl driver

Added by kervala almost 11 years ago. Updated almost 9 years ago.

Status:Closed Start date:11/27/2008
Priority:Urgent Due date:
Assignee:kervala % Done:

100%

Category:NeL: General
Target version:Version 0.7.0

Description

When a shape is using reflects maps, texture is not correctly rendered.

We could compare with older versions of opengl driver.

spec_box_left.png - DDS Texture after conversion in RGBA (1 kB) kervala, 11/29/2008 12:41 pm

History

#1 Updated by kervala almost 11 years ago

  • File spec_box_left.png added
  • Category changed from 3d - OpenGL to 3d
  • Assignee set to kervala
  • Priority changed from High to Urgent
  • % Done changed from 0 to 50

The bug is in CBitmap::convertToType when converting a DXT1Alpha testure in RGBA.

It's reproductible only when using a .dds texture in a CTextureCube with OpenGL driver because D3D driver is managing by itself the DDS conversion.

#2 Updated by kervala almost 11 years ago

  • Category changed from 3d to Misc

#3 Updated by kervala almost 11 years ago

  • Status changed from New to Resolved
  • % Done changed from 50 to 100

Applied in changeset r548.

#4 Updated by kervala almost 11 years ago

We were assuming DXT1 textures always had an alpha channel, which is incorrect.

#5 Updated by kervala over 10 years ago

  • Status changed from Resolved to Closed

#6 Updated by kervala almost 9 years ago

  • Project changed from NeL to Ryzom
  • Category deleted (Misc)
  • Target version deleted (Version 0.7.0)

#7 Updated by kervala almost 9 years ago

  • Category set to NeL: General
  • Target version set to Version 0.7.0

Also available in: Atom PDF