Bug #1496

Fall back to OpenAL default device

Added by simco about 7 years ago. Updated about 7 years ago.

Status:Resolved Start date:09/28/2012
Priority:Normal Due date:
Assignee:kervala % Done:

100%

Category:OS: GNU/Linux
Target version:Version 0.9.0 Estimated time:0.00 hour

Description

On my system (64-bits ArchLinux: Linux 3.5.3, Glibc 2.16, OpenAL 1.14, Alsalib 1.0.26), the NeL OpenAL driver can't find a proper output device. The game has no sound and crashes when unticking and ticking again “Enable sound”.
Here is a patch that fixes the former issue —finding a proper output device— by making the NeL OpenAL driver fall back to a default device.

openal_fall_back_to_default_device.diff (828 Bytes) Magnifier simco, 09/28/2012 10:01 pm

History

#1 Updated by simco about 7 years ago

Just to make it clear, it also indirectly fixes the crash when re-enabling sound, which was caused by an assertion:

2012/09/27 19:32:59 <Unknown> WRN f5351700 main_loop.cpp 847 : Creating sound manager...
2012/09/27 19:32:59 <Unknown> AST f5351700 singleton.h 136 : "_instance() == NULL" 

#2 Updated by kervala about 7 years ago

Thanks a lot for your patch, I'll try it and commit this week-end :)

#3 Updated by kervala about 7 years ago

  • Status changed from New to Validated
  • Assignee set to kervala

#4 Updated by kervala about 7 years ago

  • Status changed from Validated to Resolved
  • % Done changed from 90 to 100

Applied in changeset commit:89347b2b591f.

Also available in: Atom PDF