Bug #1343

Content in Help window not show

Added by hook over 7 years ago. Updated over 7 years ago.

Status:New Start date:08/14/2011
Priority:Normal Due date:
Assignee:- % Done:


Category:OS: GNU/Linux
Target version:-


When accessing in game help through Help → Help, where the help content should be, there is just a short error like e.g. "Error: The page address is malformed: file:/gamedev.bnp@help_en.html"

With the help of Kaetemi I have tried what happens when I place a simple HTML file in the 'data/' folder and in that case all that happens is that the error changes to e.g. "Error: The page address is malformed: file:/data/help_en.html".

Otherwise the in game browser seems to work — I tested it on E-mail, Forum etc. and the Help window is the only ones that doesn't.

Also 'log.log' doesn't mention any error or warning regarding this bug.

screenshot000.png - Screenshot of the two buggy windows — Help and Encyclopedia (1.5 MB) hook, 08/14/2011 11:56 pm


#1 Updated by kervala over 7 years ago

It seems like local HTML files can't be parsed by libwww because to a crash while passing FILE* as custom pointer.

See this issue #892

#2 Updated by hook over 7 years ago

Can I help pin-point this bug in any way?

#3 Updated by hook over 7 years ago

I tried what happens if I install libwww-5.4.0 ...and the anwser is as short as annoying: nothing — the bug persists.

Also available in: Atom PDF