Bug #1116

NLSOUND::ESoundDriverGenBuf

Added by Gulivert over 8 years ago. Updated about 7 years ago.

Status:Rejected Start date:10/03/2010
Priority:High Due date:
Assignee:kaetemi % Done:

0%

Category:OS: Mac
Target version:-

Description

Here a new bug on the OSX platform. I login and choose my avatar, the loading work fine and when the game start, the crash appear with this error. I tried to play three times and always the same crash. My avatar is in a capital, I just leave the first Island, during my play in the Island I have never got a problem like that.

terminate called after throwing an instance of 'NLSOUND::ESoundDriverGenBuf'
  what():  Unable to generate sound buffers
Abort trap

nlsound_crash.rtf (40.3 kB) Gulivert, 10/03/2010 09:32 am

History

#1 Updated by kervala over 8 years ago

  • Status changed from New to Validated

I have this error too when appearing in Pyr :)

#3 Updated by rti almost 8 years ago

Btw, Gulivert, if you just want to play, you can disable the sound.

Put this into ~/Library/Application\ Support/Ryzom/client.cfg

SoundOn = 0;

#4 Updated by rti almost 8 years ago

  • Priority changed from Normal to High

#5 Updated by kaetemi about 7 years ago

  • Status changed from Validated to Assigned
  • Assignee set to kaetemi

#6 Updated by kaetemi about 7 years ago

  • Status changed from Assigned to Rejected

The code path referenced in the attachment no longer exists in the new music implementation.

#7 Updated by kaetemi about 7 years ago

This was caused by a very bad and unstable implementation of the music channel system in the OpenAL library driver.

Also available in: Atom PDF