cannot open input file 'd3dx9.lib' (Windows VS2008 SP1)

Added by VinnyQ about 9 years ago

I am not sure how to go about this, so I am just going to post it here. Sorry in advance if this is the wrong place.

The new build instruction linked from the main page: http://dev.ryzom.com/wiki/ryzom/BuildForWindows (very concise and organized/useful btw)

is missing a step in the section "Visual Studio Configuration" to add the DirectX SDK includes and libs to the VC++ Directories (even though the image graphic did hint at it).

For total newbies to VS C++ and the DirectX SDK environment, they'll be lost (like I was).

You'll see error messages such as

"cannot open input file 'd3dx9.lib'"

It might be good to just add them to the "For 32 bits platform" and "For 64 bits platform" to add the "Include" and "Library" also, after the "external" include and lib, but before ryzom and nel stuff.

e.g.

For 32 bits platform

Section "Include"

r:\external\include\stlport (at the first position)

C:\Program Files\Microsoft DirectX SDK (February 2010)\Include

r:\code\nel\include

r:\external\include

Section "Executable files"

r:\external\bin

Section "Library"

r:\external\lib

C:\Program Files\Microsoft DirectX SDK (February 2010)\Lib\x86

r:\code\nel\lib

I am posting this here for anyone encountering those directx sdk error messages during initial build, but maybe someone can also edit that build instruction?


Replies (3)

RE: cannot open input file 'd3dx9.lib' (Windows VS2008 SP1) - Added by kervala about 9 years ago

DirectX SDK isn't setting its folders itself ? (like Platform SDK)

RE: cannot open input file 'd3dx9.lib' (Windows VS2008 SP1) - Added by molator about 9 years ago

First time i didn't have to.
Second time i had to add DirectX SDK paths myself too.

(1-3/3)