Bug #1486

clustered_sound.cpp 202 update : CClusteredSound::update : no scene specified !

Added by shackra almost 6 years ago. Updated almost 6 years ago.

Status:Resolved Start date:07/22/2012
Priority:High Due date:
Assignee:kaetemi % Done:

100%

Category:NeL: General
Target version:Version 0.9.0

Description

after login, I'm experienced a freeze state of ryzom_client. Checking with GDB I caught this:

(gdb) stepi
postlogInit () at /build/src/shackra-ryzom-3222b96eed75/code/ryzom/client/src/init.cpp:1208
1208    /build/src/shackra-ryzom-3222b96eed75/code/ryzom/client/src/init.cpp: No existe el fichero o el directorio.
(gdb) finish
Run till exit from #0  postlogInit () at /build/src/shackra-ryzom-3222b96eed75/code/ryzom/client/src/init.cpp:1208
[New Thread 0x7f3db6711700 (LWP 4251)]
[Thread 0x7f3db6711700 (LWP 4251) exited]
[New Thread 0x7f3db6711700 (LWP 4252)]
[New Thread 0x7f3db1f0f700 (LWP 4253)]
[New Thread 0x7f3db170e700 (LWP 4254)]

Nothing happens after that, killall ryzom_client is needed in order to close the game.
Checking the log.log file, the last line there is «clustered_sound.cpp 202 update : CClusteredSound::update : no scene specified !»
This issue was reported too by the user Thaodan at http://dev.ryzom.com/boards/18/topics/6197?r=6212#message-6212 I think he used a different cmake options to build the game, however, here is the cmake options which I used to build and packaged the game https://projects.parabolagnulinux.org/abslibre.git/tree/pcr/ryzom-client/PKGBUILD?id=ffad4b6353348cf713d50662f7224ed916cadf44#n33

log.log - log.log file (316.5 kB) shackra, 07/22/2012 11:50 pm

History

#1 Updated by shackra almost 6 years ago

if the problem is fixed http://dev.ryzom.com/boards/18/topics/6197?r=6236#message-6236 somebody should close this bug report :)

#2 Updated by kaetemi almost 6 years ago

  • Category set to NeL: General
  • Status changed from New to Resolved
  • Assignee set to kaetemi

Issue fixed by making the game use more reliable timing functions.

#3 Updated by kervala almost 6 years ago

Great job Kaetemi :)

#4 Updated by kervala almost 6 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF