Bug #1152

FindLibwww does not make all needed libs link to ryzom_client

Added by rti about 8 years ago. Updated about 8 years ago.

Status:Closed Start date:10/31/2010
Priority:High Due date:
Assignee:kervala % Done:

100%

Category:Build
Target version:Version 0.8.0

Description

Happens on MacOS X libwww installed using macports.

Changing all the FIND_WWW_LIBRARY(XXX OPTIONAL xxx) to FIND_WWW_LIBRARY(XXX REQUIRED xxx) fixes this, but... :)
Details follow...

History

#1 Updated by kervala about 8 years ago

  • Status changed from New to Validated

We shouldn't overlink because it can create problems for other platforms.

We created some helpers to check if a lib is using a symbol and if a lib is already linked to another one, we should use/fix them to be sure all checks are made.

If you have undefined symbols when linking, you could paste errors there and we can find what lib is missing :)

otool is working fine under Mac OS 10.5 but apparently that's not the case under Mac OS 10.6, so I replaced otool by nm to check symbols.

#2 Updated by rti about 8 years ago

Ok here is the list of missing symbols and libs containing the symbols which i had to set to REQUIRED to make ryzom_client run on 10.6 with macport's libwww:

_HTGuess_new referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwstream.dylib)
_HTLoadFTP referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwftp.dylib)
_HTLoadGopher referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwgopher.dylib)
_HTLoadNews referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwnews.dylib)
_HTLoadTelnet referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwtelnet.dylib)
_HTXML_new referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwxml.dylib)
_HTZLib_inflate referenced from /opt/local/lib/libwwwapp.dylib (is in libwwwzip.dylib)

#3 Updated by rti about 8 years ago

btw, i updated to r1049 before creating the list :)

#4 Updated by rti about 8 years ago

Maybe it is worth mentioning that some part of the under link detection seems to work well:

-- Underlinking found: /opt/local/lib/libwwwapp.dylib needs 
          /opt/local/lib/libwwwcache.dylib but is not linked to, manually linking...
-- Linking with /opt/local/lib/libwwwcache.dylib

#5 Updated by kervala about 8 years ago

Your 2nd post helped me to check that "nm -gu" are not giving the expected results :( Even if they work under Leopard.

I used now "nm -Dgu", please could you try if it works ? Thanks :)

#6 Updated by kervala about 8 years ago

  • Status changed from Validated to Assigned
  • Assignee set to kervala
  • Priority changed from Normal to High

#7 Updated by kervala about 8 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Applied in changeset r1063.

#8 Updated by kervala about 8 years ago

  • Target version set to Version 0.8.0

Finally :)

#9 Updated by kervala about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF